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Steve Jobs unveiled iLife ’04 at the Macworld Expo in
January. It’s a suite of five programs, which you can buy
from the Apple store or find preinstalled on new Macs:

• iTunes 4.2, the digital jukebox software for Mac (and, if
you can believe it, Windows) that “rips” songs from your
music CDs onto your hard drive, organizes and plays your
music collection, lets you buy songs from the iTunes Mu-
sic Store, and syncs all your music with your iPod. (No
new features debuted in the iLife ’04 package, so you won’t
read much about iTunes in this booklet.)

• iPhoto 4, the program that sucks in your photos from a
digital camera, helps you organize them, and then pre-
sents them to the world—as a slideshow, Desktop picture,
screen saver, email attachment, Web page, DVD, print-
out, or hardbound photo book.

Question: What ever happened to iPhoto 3? Answer: there never was one.
It just seemed too strange to build iLife ’04 out of a mishmash of different
version numbers, so Apple jumped directly from iPhoto 2 to iPhoto 4. Bear
that in mind the next time you’re tempted to bid on an “unopened, shrink-
wrapped copy of iPhoto 3” on eBay.

• iMovie 4, the software that forever revolutionized the con-
cept of home movies, turning them from six-hour tedium
marathons to short, sweet, tightly edited highlights reels
that friends actually ask to see.

Introduction
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• iDVD 4, which can transform iMovie productions and
digital slideshows into Hollywood-style DVDs that play
on everyday DVD players.

• GarageBand, an all-new program that turns your Mac into
a digital music recording studio. For anyone with any mu-
sical talent or even musical interest, GarageBand is every
bit as revolutionary as iMovie and iPhoto were when they
debuted. All three tear down the technical barriers that
stand between you and professional-caliber work.

This booklet is a handy cheat sheet to the new features in
these programs. It’s designed to tide you over until you can
get your hands on the full-length books slated for 2004:

• iPod & iTunes: The Missing Manual by J.D. Biersdorfer

• iPhoto 4: The Missing Manual by David Pogue, Joseph
Schorr, & Derrick Story

• iMovie 4 & iDVD: The Missing Manual by David Pogue

• GarageBand: The Missing Manual by David Pogue

• iLife ’04: The Missing Manual, which incorporates the es-
sentials of the other four books.

Note: In this book series, arrow notations simplify folder and menu instruc-
tions. For example, “Choose a→Dock→Position on Left” means, “From
the a menu, choose Dock; from the submenu, choose Position on Left.”

About the Author
David Pogue (david@pogueman.com) is the weekly technol-
ogy columnist for the New York Times, tech correspondent
for CBS News Sunday Morning, and the creator of the Miss-
ing Manual series. Details on him await at www.davidpogue.
com, and on this book series at www.missingmanuals.com.
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Even in version 1, iPhoto pounded a silver spike through
the heart of what Steve Jobs calls the “chain of pain”—
the hassle of getting your photos out of the camera

and onto the computer.

Despite the brilliance of the program, however, one criticism
dogged it year after year: it was just too gosh-darned slow. By
the time you filled it with 2,000 pictures or so, iPhoto had all
the pep of a pet rock. Web sites and books described ugly
workarounds, like breaking up your Photo Library into
smaller chunks.

iPhoto 4 ends the tyranny of sluggishness. Even on a Mac of
average speed, keeping 15,000 or 25,000 photos in a single
iPhoto library is no big deal. Switching between modes,
changing slideshows, zooming out and back, opening the
program to begin with—Apple has goosed the speed of just
about everything.

For digital camera fans, that single improvement could jus-
tify the price of the iLife ’04 suite right there. But there’s much
more to the package—and much more to iPhoto 4.

The Post-Dump Slideshow
What’s the first thing you want to do after dumping fresh
photos off the camera into iPhoto?

Look at them, of course. View them at full-size for the first
time. Rotate the pictures that you took with the camera
turned 90 degrees. Delete the stinkers.

iPhoto 4

chapter

1
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The obvious iPhoto tool for this purpose has always been
the slideshow. Unfortunately, every time you spotted a photo
that needed help (or needed trashing), you had to cancel the
slideshow, make the change, and then start the show again.

In iPhoto 4, everything has changed. Immediately after im-
porting your photos, click the Last Roll icon in the Source
list at the left side of the screen, and then click the Play tri-
angle underneath the Source list. Once the slideshow begins,
wiggle your mouse to summon the new slideshow control
bar shown in Figure 1-1.

As you can see by the figure, this is the perfect opportunity
to throw away lousy shots, fix the rotation, and linger on cer-
tain photos for more study—all without interrupting the
slideshow. You can even apply a rating by clicking the appro-

Back, Pause, Next Rotate Ratings Delete This Photo

Figure 1-1: As the slideshow progresses, you can pause the show, go backward, rotate
a photo, delete a bad shot, or apply your star rating to a picture, all courtesy of this
new control bar. (If you’d rather have it visible during all slideshows of this album or
roll, click the Slideshow button at the bottom of the screen and turn on “Display
slideshow controls.”)

The Post-Dump
Slideshow
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priate star in the band of five, exactly as in iTunes. Later, you
can exploit your ratings in several ways:

• Choose View→My Rating to see the actual stars, in gray,
stamped beneath the thumbnails of the photos you’ve
rated.

• Choose View→Arrange→By Rating to sort all the visible
pictures so that the best ones appear at the top.

• Create a smart album, described next.

More Slideshow Goodies

The control bar isn’t the only newsworthy
slideshow enhancement of iPhoto 4. If you
click the Slideshow button at the bottom of
the window, you’ll find a few other treats in
the resulting dialog box.

For example, the new Transition pop-up
menu lets you specify what kind of crossfade
you want between the slides in your show.
You can now choose several sophisticated
transitions that Apple introduced in its Key-
note presentation program, like the immor-
tal Cube effect.

Scale photos to fill the screen     means that
vertically oriented photos will no longer have
black bars on either side during the slideshow.
Instead, iPhoto will blow up each picture so
that it fills the entire screen, edge to edge.
(The downside, of course, is that some of the
picture will get chopped off—which may in-
clude your skull.)

The Display checkboxes superimpose titles,
star ratings, or slideshow controls onto the
bottom of the screen during the show.

If you click the Music tab of the dialog box
and study it hard, you’ll find one of the most
eagerly awaited new features of iPhoto: the
ability to specify an entire playlist of songs to
accompany the show. No longer must you
listen to the same two-minute pop song loop-
ing over and over again throughout your
eight-minute slideshow.

The trick is to choose the playlist name you
want from the Source pop-up menu (which
reflects the playlists that you’ve built in
iTunes). If you click Play or Save Settings now,
you’ll get the entire playlist as the background
music for this album’s slideshow. If you click
one of the songs in a playlist, however, you’ll
hear only that individual song.

GEM IN THE ROUGH

The Post-Dump
Slideshow



6 ilife ’04: the missing manual

Smart Albums
Albums are the little folder-like icons in the Source list at the
left side of the iPhoto window. These subsets of photos are
the primary organizational tool in iPhoto. You create one by
clicking the + button beneath the list, and add photos by
dragging in their thumbnails.

In iPhoto 4, though, you can let the software create albums
for you, thanks to smart albums. These are self-updating fold-
ers that display pictures that match certain criteria that you
set up—all pictures that you took in 2003, for example, or all
photos that you’ve rated four stars or higher. (If you’ve ever
used smart playlists in iTunes, you’ll recognize the idea.)

To create a smart album, choose File→New Smart Album
(Option-c-N), or Option-click the + button below the al-
bum list. Either way, the Smart Album sheet slides down from
the top of the window (Figure 1-2).

The controls here are designed to set up a search of your photo
library. Figure 1-2 illustrates how you’d find pictures that you

Figure 1-2: The Smart Album dialog box is really just a powerful search command,
because iPhoto is really just a powerful database. You can set up certain criteria, like
this hunt for photos taken during a certain time period. iPhoto will keep this album
updated whenever your collection changes (as you change your ratings, as you take
new photos, and so on).

The Post-Dump
Slideshow
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took in the last two months of 2003—but only those that have
four- or five-star ratings and mention your friend Casey in
the title or comments. You can also limit a smart album’s reach
by looking for pictures by specified album, by text in their
comments or keywords, by dates or file names, by “film roll”
(import batch), or by title. (Click the + button to add a new
criterion row to specify, for example, photos taken within a
certain date range and bearing a certain star rating.)

When you click OK, your smart album is ready to show off.
When you click its name in the Source list (it has a little gear
icon), the main window shows you the thumbnails of the
photos that match your criteria. As time goes on and you
add new photos to your collection, this collection of thumb-
nails updates itself accordingly.

Tip: To change the parameters for a smart album, click its icon in the list and
then choose Photos→Show Info (c-I). The Smart Album sheet reappears.

Recent Rolls
In previous iPhoto versions, the top of the Source list in-
cluded one icon called Photo Library (every picture in your
collection), and another called Last Import (the most recently
imported batch).

That structure wasn’t always the most convenient, however.
If you dumped your pictures onto the Mac at the end of each
day of a three-day Disney World trip, for example, the Last
Import feature wasn’t much help. What you really wanted to
see was the last three digital dumps in one group.

iPhoto 4 makes all of this much easier. At the top of your
Source list, you’ll find these new or enhanced icons:

• Photo Library. If you click Photo Library, you see every
single photo in your collection, just as before. But if you

Smart Albums
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click to expand the flippy triangle, you’ll see that iPhoto
can also break your photos down by year (Figure 1-3).

• Last 2 Rolls. In iPhoto terminology, a film roll is one batch
of imported photos from your camera (not to be con-
fused with a film role, which is one batch of sudden fame
in Hollywood).

This icon replaces the old Last Import icon—and it’s a lot
better, because you can specify how many recent import
jobs appear in this collective group. You specify how many
film rolls you want listed here by choosing iPhoto→ Pref-
erences. On the General tab, change the number where it
says “Show last __ rolls album.” (In the unlikely event that
you don’t find this icon useful, you can also hide it en-
tirely by turning off the corresponding checkbox.)

• Last 12 Months. This new icon reveals your most recent
photos, clustered by time rather than by import job. You
can specify how many months’ photos appear in this
heap—anywhere from one month to a year and a half—
on the General tab of iPhoto Preferences.

Tip: While you’re in Preferences, don’t miss the “Show photo count for al-
bums” option. As shown in Figure 1-3, it places a number in parentheses
after each album name, representing how many pictures are inside.

Figure 1-3: In iPhoto→Preferences, you
can specify whether or not you want
these organizational icons to appear,
and how many months or rolls they
represent.

Recent Rolls
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Batch Processing
iPhoto 4 now offers a batch processing feature. To use it,
choose Photos→Batch Change, or Control-click some se-
lected photos and choose Batch Change from the contextual
menu.

Now, iPhoto 4 still can’t edit a batch of photos. You can’t, for
example, scale them all down to 640 x 480 pixels, or apply
the Enhance filter to all of them at once.

Instead, the Batch Change command manipulates text labels
for a selected group of photos. When the Batch Change sheet
drops down from the top of the window, you can use its pop-
up menus to change all the selected photos’ names (to Ski
Trip 1, Ski Trip 2, and so on); to change the dates they were
taken, in effect rewriting history; and to change their Com-
ments boxes to a certain matching blurb.

Photo Sharing on the Network
One of the coolest features of iTunes is the way you can “pub-
lish” certain playlists on your home or office network, so that
other people in the same building can listen to your tunes.
Why couldn’t iPhoto do the same thing with pictures?

Now it can. On your Mac, choose iPhoto→Preferences and
click Sharing. Turn on “Share my photos” (Figure 1-4). Specify
a password, if you like, and then close the window.

At this point, other people on your network will see your
albums show up in their Source lists, above the list of their
own albums. (Or at least they will if they have “Look for
shared photos” turned on in their iPhoto preferences, as
shown in Figure 1-4 at top.)

As you may know, when you share iTunes music over a net-
work, other people can only listen to your songs—they can’t
actually have them. (The large, well-built lawyers of the
American record companies have made sure of that.)

Recent Rolls
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Figure 1-4: If
you turn on
“Share entire
library,” you
make all of
your pictures
available to
others on the
network.
Alternatively,
click “Share
selected albums”
and turn on the
individual
albums that you
want to make
public.

But iPhoto is another story. Nobody is going to issue you a
summons for freely distributing your own photos. So once
you’ve jacked into somebody else’s iPhoto pictures via the
network, feel free to drag them into your own iPhoto albums,
thereby copying them onto your own Mac. Now you can edit
them, print them, and otherwise treat them like your very
own photos.

Miscellaneous Goodies
As you explore iPhoto, you’ll find all kinds of other nips and
tucks that make the program even more pleasant:

• When you publish photos to a .Mac Web page, you have
more canned layout designs to choose from—namely, the
17 of them that are available to .Mac members who cre-
ate Web pages online. There’s also a new photo book lay-
out called Collage that lets you specify captions for some

Photo Sharing on
the Network
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pages but not for others. (Ordering these gorgeous photo
books is no longer limited to U.S. photo fans, either.)

• In Edit mode, the Black and White button is now joined
by a Sepia button, which makes the selected photo look
old and brownish, for that old-time daguerreotype look.

• The new File→New Film Roll from Selection command
creates a new film roll from a batch of highlighted pho-
tos, thus splitting them from their original roll. (That’s a
first for iPhoto. In the old days, the only way to create a
new film roll was to import a new batch of photos from a
camera or the Finder.)

Tip: You can also drag a photo onto the Film Roll header of any other film
roll to move it there.

• Similarly, the File→New Album from Selection command
saves you a few steps when you want to file away a par-
ticular clump of pictures into a new album.

Miscellaneous
Goodies
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At first glance, iMovie 4 looks identical to iMovie 3.
But under the hood, dozens of annoyances have been
eliminated and dozens of polished touches have been

added. This is the best possible kind of upgrade: one that’s
filled with nearly invisible changes designed expressly for
people who actually use it every day, rather than flashy big-
ticket items for showing off at trade shows.

Editing Enhancements
Editing is really what iMovie is all about, so any assistance is
welcome. Here are some things that will make your iMovie
life easier.

Nondestructive Edge Dragging
Nobody starts and stops recording precisely when the action
begins and ends; life is just too unpredictable. So the first
thing most people do in iMovie is to trim the shots—chop
the boring parts off the beginning and ending of each clip
before dragging them onto the timeline.

In iMovie 4, there’s a much easier way. Instead of chopping
off the ends of your clips, you can just hide the ends of your
clips, as shown in Figure 2-1. (This kind of nondestructive
edge dragging also works with audio clips.)

Tip: If you c-drag a clip in the Timeline Viewer, you can move it right on top
of an adjacent clip, in effect trimming the part that the dragged clip is now
covering up.

iMovie 4

chapter

2
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Editing
Enhancements

Select Nonadjacent Clips
For the first time, you can select several clips that aren’t next
to each other. Switch into Clip Viewer mode (choose View→
Switch to Clip Viewer, if necessary). Now you can use the
same techniques you’d use to select nonadjacent icons in a
Finder list view: Click the first clip, then c-click each addi-
tional clip. You can also c-click a selected clip to deselect it.

What can you do once you’ve selected multiple discontinu-
ous clips? Let us count the tricks:

• Delete them all by pressing the Delete key.

• Move them all back to the Clips pane by dragging any
one of them. (The remaining clips slide to close the gaps.)

• Apply the same transition, special effect, or Ken Burns
photo setting to all of them using the Apply button (on
the Trans, Effects, and Photo panes)—or update them all
using the Update button.

Tip: Speaking of the Ken Burns zoom-and-pan photo effect: If you Option-
drag a set of photos from the Photos pane into the timeline, iMovie applies
the Ken Burns effect to all of them, alternating zoom direction on each one.

• Consolidate them. That is, you can extract the selected
clips from their current positions in the movie (Edit→
Cut). Click a different clip in the movie to pinpoint a land-
ing site, and then choose Edit→Paste. The clips that you
cut, which were once scattered, now appear adjacent to
each other and in sequence.

Bookmark Your Place
Navigating complex movies is a lot easier in iMovie 4, thanks
to the new Bookmarks feature.

It works like this: Position the Playhead at an important spot
in the movie, and then choose Bookmarks→Add Bookmark
(c-B). iMovie responds by placing a tiny green diamond at
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that spot on the ruler (you can see a couple of them in Figure
2-2). Bookmarks are visible only in Timeline Viewer mode.

You’ll see the real value of these markers once you’ve added a
few of them to your movie. Now you can use the Previous
Bookmark and Bookmark commands (c-[ and c-], respec-
tively) to leap instantly from one marker to the next.

Note: You can remove an individual bookmark by clicking it and then choos-
ing Bookmarks→Delete Bookmark, or all of them at once by choosing
Bookmarks→Delete All Bookmarks.

Color Clips
In previous versions of iMovie, you could create a few sec-
onds of pristine blackness by dragging any video clip to the
right in the Timeline Viewer. In the resulting gap, iMovie
introduced a solid black clip.

In the new version, dragging a clip to the right still intro-
duces blackness in the gap during playback, although you
don’t actually see a black bar in the Timeline Viewer (you
just see a gap).

But if you deselect all clips, position the Playhead anywhere
inside of that gap, and then choose Advanced→Create Color
Clip, iMovie creates a visible clip that looks like a black slide.

Here comes the fun part. If you double-click this new clip,
the Clip Info dialog box appears. It lets you name the clip
and, more important, click the Color swatch to bring up the
standard Mac OS X color picker dialog box.

In this way, you can create a few seconds of any solid color—
not just black—to serve as a transition between scenes, a back-
ground for titles and credits, or just a soothing moment of
pure, perfect fuchsia.

Editing
Enhancements
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Three Audio
Improvements

Three Audio Improvements
When you examine the new iMovie Preferences dialog box,
you’re in for a few pleasant surprises. One of them is an op-
tion called “Show audio track waveforms.” When you turn it
on, you see the actual sound waves, as shown in Figure 2-2.
Seeing the waveforms makes precise video editing much
easier—eliminating a pop or an expletive, for example—or
to sync up audio with video.

While you’re in Preferences, you might also want to turn on
“Enable Timeline snapping.” Now, when you drag the Play-
head along the ruler in the Timeline Viewer, you see, hear,
and feel it “snap” to the beginnings and ends of the sound-
wave chunks in the soundtracks below, also as shown in Fig-
ure 2-2. (You turn off the little clicking sound in this same
dialog box.)

Like the snapping? Then you’ll love these tips:

• When Timeline snapping is turned on, the Playhead also
snaps to bookmarks, chapter markers, and the beginning
and ends of clips.

• Snapping is extremely useful when you’re seeking a good
place to split an audio clip—like during a bit of silence.

• This feature can also be useful when you want to align a
video clip with a certain moment in the music. Drag the
Playhead to the appropriate spot in the soundtrack. Re-
lease the mouse. Now, when you drag a video clip, a ghost

Figure 2-2: The only
downside to turning
on waveforms is that
doing so could slow
down scrolling in very
complex projects.
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version of the Playhead (with a snap line extending down
from it) remains where you left it, so that you have an
easy target as you position the video clip.

• If you Shift-drag the Playhead, you override whatever the
Playhead-snapping setting in Preferences is. If snapping
is off, Shift-drag to turn it on just for this moment.

The final audio-precision feature is audio scrubbing. If you
Option-drag the Playhead, you get to hear the actual audio,
played forward or backward, at whatever speed you’re drag-
ging. This is another excellent tool for hunting down some
annoying audio artifact or lining up a particular “hit” in the
audio with a specific action in the video.

Tip: This feature works best if you zoom in first, using the Zoom slider at the
lower-left of the screen. It also helps to drag very slowly, to avoid making
your soundtrack sound like “Alvin and the Chipmunks Do Helium.”

The View Menu
Previous versions of iMovie didn’t even have a View menu,
which is sort of strange for such a visually oriented program.

In any case, you’ll welcome these new commands:

• Switch to [Clip or Timeline] Viewer. This command lets
you toggle the bottom part of the iMovie screen between
the two views.

Actually, it’s not the menu command that’s so great: it’s
the keyboard shortcut, c-E. No matter which view you’re
in, c-E switches to the other one.

• Scroll to Playhead. If you’ve managed to lose the Play-
head while scrolling, this command jumps to its position
in the Timeline, pulling the Playhead into view.

• Scroll to Selection. This command scrolls the Timeline
to reveal whatever clips are highlighted at the moment.

Three Audio
Improvements
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The View Menu • Zoom to Selection. Start by highlighting a clip or two that
you want to work with in the Timeline Viewer. Then use
this command. iMovie dutifully zooms into the Timeline
so that your selection fills the entire width of the screen,
making it much easier to fine-tune minute video moments
or audio problems.

Miscellaneous Improvements
Tiny touchups are everywhere in iMovie 4. For example:

• The old File→Export menu command is now called File→
Share, and it offers a few new options (Figure 2-3). Among
them: “Share selected clips only,” which lets you export
only a segment of your movie. (It’s available only if you
had selected several consecutive clips before choosing the
Share command.)

• You can choose some new title effects, including one called
“Far, Far Away.” (Can you guess what it looks like, Star
Wars fans?) Also, the title styles are now grouped by flippy
triangles to make the list easier to navigate.

Figure 2-3: You
can now post a
finished iMovie
directly to your
.Mac HomePage
Web page—or
even send a
highly com-
pressed version to
a Bluetooth-
equipped (and
“3GP-compat-
ible”) cellphone,
Palm organizer,
Mac, or PC!
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Figure 2-4: Once
an iSight camera is
connected, the
camcorder icon
sprouts a pop-up
menu. Use it to
choose the iSight as
the video source.

Miscellaneous
Improvements

• iMovie 4 processes just about everything faster: effects,
transitions, Ken Burns–style zooming and panning, and
so on.

• Attention efficiency freaks! Control-clicking thrives in
iMovie 4. You get useful contextual menus when you Con-
trol-click all kinds of things in iMovie 4: clips (video, au-
dio, title, transition), the Playhead, the Scrubber bar (un-
der the Monitor window), empty space in the Timeline
Viewer, and so on.

• You can use an Apple iSight video camera as though it’s a
camcorder. As shown in Figure 2-4, a new pop-up menu
appears that lets you choose which video source you want
to use for capturing new video.
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If your Mac has a built-in SuperDrive (a drive that can
both play and record both CDs and DVDs), then you
probably already know about iDVD. It’s the software that

lets you turn your iMovie movies and iPhoto slideshows into
Hollywood-style DVDs that play on most standard DVD
players.

As you’ll see in the following pages, iDVD 4 is loaded with
enhancements that help you make your DVD look even more
like a commercial Hollywood DVD.

But before you even get that far, you’ll discover one welcome
change: iDVD now runs on Macs that don’t have SuperDrives.
Of course, you still need a SuperDrive to burn a DVD—but
now you can do the design work on another machine. That’s
a great feature in, for example, school computer labs that
have 12 Macs, but only two that can burn DVDs. (To trans-
fer a DVD project to a different Mac, use the File→Archive
Project command. Then copy the resulting “bundle file” to
the Mac with a SuperDrive.)

New Themes
Version 4 comes with 20 new themes (ready-to-use menu
screen designs complete with attractive backgrounds and
coordinating type, music, and graphics). To see them, click
the Customize button at the bottom of the main window;
the Customize drawer slides open at the side. Click the
Themes button at the top to see them all.

iDVD 4

chapter
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New Themes Tip: Actually, you have 44 themes available in all. Use the pop-up menu at
the top of the panel to see the 24 themes from the previous version of iDVD.

Some of the new themes appear twice: “Wedding Theme
Bronze One” and “Wedding Theme Bronze Two,” for example.
That’s a harbinger of another iDVD new feature: predesigned
submenu screens, like the Scene Selection screens you’d find
on a commercial DVD. The “Two” designs are intended for
these second-level screens of buttons.

Fewer Limits
Overall, the most important change in iDVD is the removal
of limits that were present in previous versions. You can put
12 buttons on a menu page, up from six. You can now resize
and move them freely. You can play 15 minutes of tunes as
background music on a menu screen, not just 30 seconds.
You can create up to 99 chapter markers per movie—the
maximum possible in the DVD format—up from 36.

And you can now create text boxes on your menu screens
and fill them with instructions, introductions, a description
of the project, and so on. (To do this, choose Project→Add
Text. Double-click the placeholder text and type away. Use
the Settings panel of the Customize drawer to specify the font,
color, and size of the text.)

The DVD Map
In previous versions of iDVD, the main menu (the screen
that appears when you first insert the DVD) generally con-
tained at least two buttons: Play Movie and Scene Selection.
If you clicked Scene Selection with the remote control, a sub-
menu screen appeared, listing up to six buttons, each capable
of playing a slideshow or little movie.

But if you had more than six movies or slideshows, you had
to click onto yet another submenu screen that had another
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six buttons. And if that still wasn’t enough room for your
buttons, you had to create another submenu. And...well, pretty
soon, you felt like Hansel and Gretel with not enough bread
crumbs.

But now, as your menu and button layouts grow more com-
plex, you can use the new Map screen to help you keep track
of your menu structure (see Figure 3-1).

Figure 3-1: As you work on your DVD menu structure, behind the scenes, iDVD builds
this handy map. You can’t add to it, or drag or delete any elements you see here, but
you can double-click one of the icons to open the corresponding menu, movie, or
slideshow. You can also click one and then click the Preview button to try out that
element on your “virtual DVD player.”

Project tile
(Drag Autoplay material here)

The menu you were
just editing

The DVD Map
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The DVD Map To view the map, just click the Map button at the bottom of
the main iDVD window. The element you were working on
appears with colored highlighting. To scroll, just drag in any
blank space. (Click the Map button again to return to the
menu screen you were working on.)

But the map is more than just a pretty navigational aid. It
also makes possible several additional iDVD 4 features.

Autoplay
Until now, you could make your homemade iDVD discs be-
have like commercial Hollywood DVDs in almost every re-
spect—except one. You couldn’t designate a video clip to play
automatically when the disc is inserted, before the menu
screen appears. You know—a bright red FBI warning, pre-
views of coming attractions, or maybe just a quick snippet
of the movie on the DVD.

iDVD 4 makes creating this kind of “pre-movie” extremely
easy. In Map view, the upper-left icon is technically called
the Project icon (see Figure 3-1), but you can think of it as
the Autoplay icon. Whatever you drag onto this tile will play
automatically when the DVD is inserted, before your view-
ers even touch their remote controls.

These are the kinds of things you can put there:

• A video clip. In the Customize drawer, click the Media
button at the top, and then choose Movies from the pop-
up menu. iDVD displays all the movies in your Home→
Movies folder; drag the one you want directly onto the
Project tile to install it there.

• A still image. In the Customize drawer, click the Media
button, but this time choose Photos from the pop-up
menu. iDVD shows your complete iPhoto collection, in-
cluding all of your albums. To use one of these images as
a startup screen for your DVD project, just drag it onto
the Project tile. (You can add audio to it, too, just as you’d
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add audio to a slideshow—by dragging in an audio file
from the Audio section of the Media pane.)

Tip: If you tinker with the graphics tools in a program like Photoshop or
AppleWorks, you can come up with a decent replica of the standard FBI warn-
ing that appears as the Autoplay of a commercial DVD. You can precisely
duplicate the wording and typographical look, or take the opportunity to do a
hilarious spoof of the usual warning.

• A slideshow. Once you’ve got the Photos list open in the
Customize drawer as described above, you can also drag
an entire iPhoto album onto the project icon. Alterna-
tively, you can click and c-click just the photos you want
in the Customize panel, and then drag them en masse onto
the project icon. In fact, you can even drag a group or
folder of photos right out of the Finder and onto this icon.

To control how long your still image remains on the screen,
or how quickly your Autoplay slideshow plays, double-click
your Project tile. You arrive at a screen like the one shown in
Figure 3-2, where you can adjust the timing, transition, and
even the audio that plays behind the picture(s).

If you decide to replace your Autoplay material, just drag new
stuff right onto it. Or, to eliminate the Autoplay segment,
drag it right off the Project tile. It disappears in a little puff
of Mac OS X cartoon smoke.

Tip: It’s possible to create a DVD that never even gets to the menu screen—
a DVD consisting only of Autoplay material. You could design a project that
way for the benefit of, for example, technophobic DVD novices whose pupils
dilate just contemplating using a remote control. They can just insert your
Autoplay-only DVD and sit back on the couch as the movie plays automati-
cally.

The DVD Map



26 ilife ’04: the missing manual

Menu Transitions

Speaking of crossfades and transitions: iDVD
can put them between menus, too. Now,
when your audience clicks a button on the
main menu screen, the screen doesn’t just
jump cut to the selected move or slideshow;
it crossfades, wipes, rotates on the face of a
cube, or whatever.

To specify which transition you’d like, open
the Customize drawer, click the Settings but-
ton at the top, and then use the Transition
pop-up menu to specify the effect you want.
(Your choice here affects all transitions into
and out of menu screens.)

GEM IN THE ROUGH

The DVD Map Looping
If you highlight the button for a movie, slideshow, or Autoplay
tile—either in Map view or on a menu screen—and then
choose Advanced→Loop Movie (or Loop Slide Show), you
unleash another raft of possibilities. You can make a DVD
that endlessly repeats the highlighted material (a slideshow
or movie) and, in fact, never gets back to the menu screen.

That would be a great way to create a DVD containing a self-
running slideshow that plays on a TV at a party or wedding
reception. You could also use it to create a self-looping kiosk
display at a trade show.

In any case, the DVD will loop endlessly—or at least until it
occurs to someone to press the Menu or Title button on the
remote, which displays your main menu at last. (The Menu
button redisplays the previous menu screen; the Title button
causes a return to the main menu.)

Slide Shows
The DVD has always been a fantastic delivery mechanism
for slideshows. The pictures look great on a TV, music plays,
and your grateful viewers can control the pace using the re-
mote control (if you give them that freedom).
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iDVD 4 makes setting up slideshows even easier. You begin
as you always have—by opening the Customize drawer, click-
ing the Media button, choosing Photos from the pop-up
menu, and dragging an album (or a selected group of pic-
tures) onto a menu screen. (You can also drag a folder full of
pictures right out of the Finder and onto the menu screen.)

As before, iDVD creates a button that links to those pictures.
But in iDVD 4, you can double-click this button to open a
new Slide Show editor, shown in Figure 3-2.

Figure 3-2: You can change from this thumbnail view to a list view by clicking the list
icon in the upper-right.

Slide Shows
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Here, you can rearrange slides by dragging them (the other
slides scoot aside to make room), delete selected slides with
the Delete key, or add new photos from the Customize drawer.

Then, of course, there are the controls at the bottom of the
window. As in previous iDVD versions, they let you specify
how long the slides remain on the screen (or choose Manual
to let the viewers advance the slides). But a few new goodies
are here:

• Transition. Now you can specify any of several graceful
transition effects—Dissolve, Cube, and so on—to govern
how one slide morphs into the next.

Note: The transition you specify here affects all slides in the show.

• Looping. If you turn on the “Loop slideshow” checkbox,
the slideshow repeats endlessly, as described on page 26.

Figure 3-3:
iDVD 4 offers
two ways to
compress the
video on your
masterpiece.

Slide Shows
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• Longer audio tracks. The music that accompanies your
slideshow must no longer end pathetically three minutes
into the presentation.

Open the Media panel of the Customize drawer. From
the pop-up menu, choose Audio. Now you see your en-
tire list of iTunes music—in fact, you even see your play-
lists here. To avoid the music-ending-too-soon syndrome,
drag an entire playlist into the little Audio well beneath
the slide display. Your DVD will play one song after an-
other according to the playlist.

Two Hours of Video
For some people, this final grace note might be the most
important new feature in iDVD 4. You no longer must make

Slide Shows

Best Quality/Best Performance: How It Works

When a DVD-burning program goes to work,
it faces an important decision. Given that a
blank DVD contains a limited amount of space
(4.7 GB or so), how much picture-quality data
can it afford to devote to each frame of video?

The Best Performance option in iDVD 4 makes
that decision like this: “I’ll allot a fixed, pre-
determined amount of data to each frame of
video—enough to make it look great—no
matter how many minutes of video my hu-
man master has included. A lot of the DVD
might wind up being empty—if, for example,
the project contains less than an hour of
video. But at least the burning process will
go quickly, and the video will look really
great.”

The Best Quality option takes a different ap-
proach. It says: “I’m going to use every mi-

cron of space on this blank DVD. I’m going
to analyze the amount of video my human
has included, and divide it into the amount
of space available on the DVD. The amount
of information used to describe an individual
frame of video will vary from project to
project, and it will take me a lot longer to
burn the DVD because I’m going to have to
do so much analysis. But at least my human
will get two hours of great-looking video per
disc.”

Incidentally, if you’d like some insight into
how iDVD is thinking of the project you’re
working on at the moment, open the Cus-
tomize drawer and click the Status button.
This new panel shows you how close you are
to filling up the DVD with your movies,
menus, and other elements.

POWER USERS’ CLINIC
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the Hobson’s choice between 60 minutes of video at best
quality and 90 minutes at lower quality. Apple has thought-
fully raided its own professional DVD creation software and
added one of its best features to iDVD: now any DVD you
burn can contain two hours of footage at the best possible
quality.

To see the on/off switch for this feature, choose iDVD→
Preferences. On the General panel (Figure 3-3), you’ll see two
options under Encoding Settings. Both produce superior
video quality to what you got from iDVD 3:

• Best Quality. This option gives you two hours of video.
From 60 to 120 minutes, the quality gradually drops as
iDVD tries to cram more and more video information
onto a finite disc—but even at two hours, the picture looks
better than 90-minute mode did in iDVD 3. And if you
have only 60 minutes of video, this option produces much
better video quality than the Best Performance setting.

This option takes a lot longer to burn your DVD, because
the program performs quite a bit of analysis before burn-
ing.

• Best Performance. Video will look fantastic, and your Mac
will burn the disc relatively quickly—but the DVD you
burn this way can contain a maximum of one hour of
video.

Tip: If you’d like some insight into how iDVD is thinking of the project you’re
working on at the moment, open the Customize drawer and click the Status
button. This new panel shows you how close you are to filling up the DVD
with your movies, menus, and other elements.

Two Hours of
Best Quality



iTunes is a music program, but its function is to organize
and manipulate music created by other people. With
GarageBand—some of whose underlying technology

Apple bought in 2002 when it acquired a company called
Emagic—Apple enters new territory. It has created a pro-
gram that lets you create music of your own.

If you’re already a musician, you’ll probably flip over
GarageBand; it combines the CD-quality samples of Apple’s
Soundtrack software with the hard-disk recording features
of Digital Performer and the canned rhythm tracks of Band
in a Box.

But what’s really mind-boggling is the way this program can
turn the inspiration of musical novices into commercial-
sounding demos. Imagine how many thousands of singers
and instrumentalists, though blessed with enormous native
talent, remain undiscovered because they lack recording stu-
dios and backup bands. For them, GarageBand may open a
lot of doors—or just offer a lot of fun.

The GarageBand Concept
GarageBand lets you construct professional digital record-
ings using three kinds of raw material:

• Prerecorded loops. The program comes with thousands
of professionally recorded musical snippets—drums, gui-
tar, bass, and dozens of other instruments. Even if you
don’t know a quarter note from a quarterback, you can
drag these musical snippets like building blocks, layering

GarageBand

chapter

4
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one track upon another until you have yourself a compo-
sition.

• Professional samples. If you have a USB keyboard—that
is, a USB musical keyboard—or a MIDI synthesizer-type
keyboard, you can use GarageBand’s built-in sequencer as
a digital tape recorder. As you play the plastic keys of your
USB instrument, your Mac speakers emit the rich sound
of a grand piano (it’s a Yamaha C7, for those scoring at
home), an orchestra full of strings, the brassy sting of rock-
hall trumpets, or any of hundreds of other sounds of your
choosing. You can lay down one such track after another—
the drum beat, followed by a bass line, then some piano,
and so on—until you’ve got a rocking little band right in
your Mac.

Tip: Apple intends to sell an expansion pack for GarageBand that includes
even more instruments and loops.

• Digital recording. Once you’ve built up an instrumental
accompaniment, using either the prerecorded loops or by
laying down some tracks with a keyboard, you can add
the icing on the cake: live recordings. Most people sing or
play into a microphone, using GarageBand as a multi-
track tape deck. But you can also plug in a guitar, synthe-
sizer, or any other sound source—and record it directly
to your hard drive.

The idea is that you can use GarageBand’s tools—prerecorded
loops, sampled sounds, live recordings—in any way you see
fit. Then you can apply professional-sounding effects like
reverb or chorusing, and then export the finished product to
iTunes, where you can download your work to your iPod,
export it as an MP3, or burn it onto CDs. Forget the Record-
ing Industry of America; GarageBand turns you into the Re-
cording Industry of Your House.

Garage Band
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Module 1:
Prerecorded Loops

Module 1: Prerecorded Loops
Here’s the part of GarageBand that you can use even if you
have no musical training—or musical equipment—whatso-
ever.

Once you’ve opened up GarageBand, choose File→New. In
the New Project dialog box, you can set the name, tempo
(speed), time signature, and key for the piece you’re about to
create (you can change any of these parameters later). Type
in name for this song and then click Create.

Note: GarageBand proposes saving new compositions into your Home→
Music→GarageBand folder, although you can file them anywhere.

Figure 4-1: GarageBand looks like an old-time guitar amp crossed with the brushed-
metal interface of Mac OS X.

Loops pane Measure counter

Audio you’ve recorded
Green loop

(editable notes)
Blue loop

(digital audio)

Playback controls
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Module 1:
Prerecorded Loops

After a moment, the GarageBand window appears. To view
the thousands of prerecorded musical tidbits (called loops),
choose Control→Show Loop Browser, or press c-L. The
buttons shown at the bottom of Figure 4-1 appear.

Now the fun begins. Click the name of the instrument you’d
like to hear—Drums, for example. At the right side of the
screen, you see a long, scrolling list of drum licks in various
styles: Alternative Rock, Classic Rock, Club Dance, and so
on. Double-click one to hear it; click again to stop playback.

Of course, it could take you all day to try out every one of
these recordings. Fortunately, there are several ways to sift
through the loops:

• Click successive rounded buttons in the Loop browser to
narrow the choices in the list of recordings. For example,
if you click Drums, then Electronic, Dark, and Intense,
you winnow down the list to only three different loops.

To bark up a different tree—for example, to try out loops
recorded by a different instrument—click the Reset but-
ton and then begin again, this time with, say, Bass.

• The loops with green icons are “software instruments,”
triggered live during playback by GarageBand’s built-in
sound samples. You can edit or transpose the notes just as
you would music that you played yourself (page 42).

The loops with blue icons are actual digital recordings of
professional studio musicians. You can’t edit the notes.
Incredibly enough, though, you can change their tempos
and even transpose them, thanks to some very slick soft-
ware voodoo.

• Click the Column View button at the lower-left corner of
the screen. Now your list of loops resembles the iTunes
category browser (Figure 4-2). The leftmost column lets
you specify how you want to search (by genres, by instru-
ments, and so on). The second column lists your options
in that category (Country, Electronic, and so on). The
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third column breaks down that option into finer subcat-
egories (Cheerful, Dry, and so on).

• In either button view or column view, you can type the
name of the instrument or feeling you’re looking for into
the Search box at the bottom edge of the browser—banjo,
ballad, Latin, or whatever—and then press Return. The
rightmost list of loops shows only the matches.

Tip: If you know a little bit about music, you can also use the Scale pop-up
menu at the bottom of the window. It lets you view only loops recorded in
major keys, minor keys, or no particular keys. (The “Good for Both” option
refers to loops that don’t clash with major or minor chords: moving octaves,
open-fifths “power chords,” and so on.)

When you’ve found a good loop, drag its name upward into
the main track window, as shown in Figure 4-3. At that point,

Module 1:
Prerecorded Loops

Figure 4-2: As in button view, the far-right listing shows the matching loops for the
subcategory you’ve now specified.

Figure 4-3: By dragging the upper-right
corner of a loop, you make it repeat for
the number of measures indicated by the
ruler. The most common use of this
feature, of course, is to “lay down” the
drum track for the entire song.
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Navigating GarageBand

You can jump around in your composition in
either of two ways:

Click in the ruler. See the measure ruler at
the top of the window? Click it to plant the
Playhead where you want playback or record-
ing to begin.

Type a specific location.     See the measure
counter—the blue digital numeric readout to
the right of the playback controls? This dis-
play can show you the position of the Play-
head in either of two ways. First, it can show
this format: 25.15.3.100, which refers to mea-
sures, beats, sub-beats (that is, quarters of a

beat), and ticks (of which there are 240 per
sub-beat). Second, it can display pure time
code (hours:minutes:seconds:thousandths of
a second). To switch between these two dis-
plays, click to the left of these digits, where
you see the tiny clock or musical note.

This isn’t just a display; it’s also a navigation
tool. Double-click the number you want to
edit (which now begins to blink), type new
numbers, and then press Return. The Play-
head jumps immediately to the point you
specified.

UP TO SPEED

it shows up as a green or blue bar, which you can drag by the
middle to reposition it.

Tip: If you drag the lower right corner of a loop, you can shorten it. That way,
you can, for example, trim down the loop to only its first half—and then, by
dragging the upper-right corner of that, make that half repeat over and over.
Also, once you’ve created several repetitions, you can move the cursor near
the indentation of the first loop repetition, and resize the duration of the area
that gets repeated.

Once you’ve deposited a loop into your composition, you
can use the tape-deck-style transport controls beneath the
track display.

Tip: The Space bar also works to start and stop playback, by the way. Don’t
forget to drag the Playhead into position before you tap it, so that you don’t
have to start from the beginning each time.

Module 1:
Prerecorded Loops
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Working with Tracks
In recording-studio jargon, a track is one of several parallel
streams of musical sound (usually one per instrument) that
all play back together.

When you drag a loop into an empty area, you create a new
track. (You can also drag a loop into an existing track.)

Note: You can also set up a new empty track by choosing Track→New Track
(Option-c-N), or by clicking the + button beneath the track list. In that case,
a dialog box lets you choose the instrument you want the new track to play.

The whole idea of GarageBand is to build a set of tracks that
sound good together. (Or, rather, that sound the way you want
them to sound; these days, good is a relative term.)

Here’s some of the other fun you can have with tracks:

• To rename a track, click its icon in the Tracks column.
Down below, you can edit the Name box in the Editor
panel. (If you don’t see it, choose Control→Show Editor,
or press c-E. Details on the Editor panel in a moment.)

• During playback, it’s frequently useful to isolate a certain
track—like shouting, “OK, everybody shut up but the
bass!” To do that, click the little pair of headphones just
beneath the track name. When it’s illuminated in blue, all
the other tracks fall silent. You’ve just soloed a track.

Tip: You can solo more than one track, isolating just two out of your five, for
example. Also, feel free to solo or un-solo a track during playback.

• Similarly, you may want to silence one track so that you
can hear the others. That’s the purpose of the tiny speaker
icon—the Mute button—beneath the track name.

Tip: The Mute button is especially useful when you’re trying to decide which
of several variations on a track is the one you want to keep.

Module 1:
Prerecorded Loops
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• You can zoom in or out of your piece—stretching or con-
densing the measure ruler at the top—by pressing Con-
trol-left arrow or Control-right arrow. (There’s a slider
below the track list that does the same thing.)

You’ll find more on working with tracks at the end of this
chapter.

Module 2: Virtual Instruments
Much more fun awaits if you’ve got a cheapo USB piano key-
board (like the M-Audio Keystation 49e that Apple sells at
its online store for $100), a MIDI keyboard with a USB in-
terface connected to your Mac, or a MIDI drum set. You can
actually record your live performances—and clean up your
mistakes afterwards. The sound you hear as you play is up to
you: a piano, string orchestra, guitar, or even a heavenly choir.

Tip: If you don’t have a USB or MIDI keyboard, you can still fool around with
GarageBand’s virtual instruments by choosing Window→Keyboard. A tiny
keyboard appears on the screen, with keys that you can “press” by clicking.

You won’t become a virtuoso using this crude tool, and of course you can’t
play more than a single note simultaneously—even with a two-button mouse.
But at least you’ll get to hear what the sounds sound like until you can get
$100 together to buy a USB musical keyboard.

Start by creating a track set to the instrument you want to
hear. For example, choose Track→New Track. The dialog box
shown in Figure 4-4 appears, where you can specify what
instrument you’ll be playing.

To try out these instruments, click an instrument family at
left and the individual instrument sound at right. Play a few
keys on your musical keyboard to hear the sound. You’ll no-
tice that GarageBand’s samples are velocity sensitive: the notes
sound louder or have stronger attack as you press harder (if
you have a touch-sensitive keyboard).

Module 1:
Prerecorded Loops
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When you’ve found the instrument you want, click OK. Re-
wind to the beginning of your new track, if necessary (al-
though you can start recording anywhere). You might want
to choose Control→Count In, which makes GarageBand play
one bar’s worth of countoff clicks before you begin—the soft-
ware equivalent of, “And-a one! And-a two! And-a three! And-
a four!”—to give you time to get your hands on the keyboard.

If you don’t already have a few tracks that will help keep you
on rhythm, choose Control→Metronome (so that a check-
mark appears). GarageBand will click off the beats as you
play to help you stay on rhythm.

Tip: You can cheat just like the pros do! You can record your performance at
a slow tempo, so that you’ll sound like a musical virtuoso when the piece
plays back faster. To specify the tempo, click and hold the word Tempo (just
to the right of the measure counter, beneath the tracks). A slider appears,
which you can drag up or down to control the playback or recording speed.

Figure 4-4: This
dialog box lists
the software
instruments
available in
GarageBand—the
sounds that you
can trigger with
a USB or MIDI
musical keyboard.

Module 2: Virtual
Instruments
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Module 2: Virtual
Instruments

Figure 4-5: If you don’t see this panel at the bottom of the window, choose
Control→Show Editor or press c-E. The darker the bar, the harder you struck the note.

Finally, click the round, red Record button. GarageBand
counts you in and then begins recording your performance,
while simultaneously playing back any other tracks that you’ve
laid down, either using canned loops or live performances.

Tip: If you’ve told GarageBand to loop a certain region as described in the
box on the facing page, you can keep “laying down” additional notes on each
repetition, building a cumulative, multi-layered instrumental part. This is a
particularly useful tactic for recording a drum part—the kick drum on the first
pass, the hi-hat on the next, and so on.

Tap the Space bar when you’re finished. Rewind, or drag the
Playhead, and then press the Space bar to play back your per-
formance.

Editing Your Performance
Nobody’s perfect, but you’d be surprised at just how imper-
fect your favorite pop musicians are. Believe it or not, just
about every song you ever hear on the radio or on an album
has had wrong notes cleaned up, emphasis added, and mul-
tiple takes sliced, diced, and recombined.

You do the same kind of work in the Editor panel, shown in
Figure 4-5.
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It may take you a moment to find the actual horizontal bars
that represent the notes you recorded. Use the scroll bars, or
drag the thick horizontal divider between the upper and lower
halves of the window to enlarge the editor window.

Tip: Another great way to get your bearings is to use the Zoom slider at the
left corner of the window.

Hear some of the ways you can edit your recording:

• Delete a bad note by clicking the horizontal bar with the
mouse to select it. (The note plays and changes color.)
Press the Delete key.

• Insert a new note. While pressing the c key, you can draw
a new note right into the Editor window.

• Drag a note up or down to change its pitch—a great way
to fix a bit of sloppy piano playing, for example—or drag
it right or left to change its position in time.

Tip: As you drag a note, it snaps to the next rhythmic grid line (quarter note,
eighth note, or whatever you’ve selected using the Grid pop-up menu de-
scribed on the next page). If you’d like to be able to drag freely, choose
Control→Snap to Grid, so that the checkmark no longer appears.

Module 2: Virtual
Instruments

Looping

GarageBand can loop a specific stretch of
music over and over again as you work, so
that you can hear the changes without hav-
ing to mess with the Play, Stop, and Rewind
buttons.

Click the Loop button at the right end of the

playback controls. Then drag through the
ruler to highlight, in yellow, the section you’d
like to record (or drag the edges of the exist-
ing yellow bar). When you click the Record
button, GarageBand cycles through that pas-
sage over and over again, as you work on
editing that passage.

GEM IN THE ROUGH
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Module 2: Virtual
Instruments

Transposing notes
Click the triangle to the right of the Region panel name (Fig-
ure 4-5) to reveal the Advanced panel. Here, you can drag
the Transpose slider to shift the pitch of selected notes. (To
transpose the whole track, choose Select All first.)

Note: Here’s also where you can adjust the velocity of the selected notes—
how hard they were struck. Velocity isn’t quite the same thing as volume,
because sometimes hitting a note harder doesn’t just make it louder—on
most instruments, it actually changes the character of the note produced.

Clean up your rhythm
When you quantize your performance, you tell the software
to nudge all of your notes so that they align with an underly-
ing rhythmic grid—to the nearest eighth notes, sixteenth
notes, or whatever.

Certain music benefits immensely from this treatment. In
fact, the debut of computerized quantization was largely re-
sponsible for the birth of disco and rap, because it gives ev-
erything a robotically perfect, mechanized-sounding rhyth-
mic feel.

Other kinds of music are better off unquantized, so that they
retain their original human feel; quantizing totally nukes
grace notes, glissandos, and subtle syncopations.

Tip: GarageBand offers 10 levels of Undo—that is, you can successively “take
back” your last 10 edits—so you should feel free to experiment with things
like quantization without fear that you’re ruining your piece.

In any case, here’s how you quantize something you’ve played
into GarageBand:

1. Click the name of the track you want to quantize.

Unfortunately, in GarageBand 1.0, you can’t quantize only
a certain region of notes—only the entire track.
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2. Using the Grid pop-up menu (the tiny, tilted-ruler but-
ton just above the Editor panel’s vertical scroll bar),
specify the degree of quantization you want.

Do you want your notes nudged so that they begin at the
nearest eighth note, sixteenth note, or triplet? This pop-
up menu even offers four levels of swing, meaning that
the software will nudge your notes more or less toward
dotted-eighth-and-sixteenth or triplet rhythms.

3. In the Region panel at the left side of the Editor panel,
click Fix Timing.

This button is dimmed if any notes are selected in the
Editor panel, since you can quantize only an entire track.
(Click an empty spot on the Editor panel to deselect
them.)

After performing the quantization, play back the result to
make sure you haven’t over- or under-quantized, wiped out
grace notes, or suffocated the humanity of your performance.
(And if so, choose Edit→Undo.)

Copying and pasting
Most music is, to some degree, repetitive, so the Cut, Copy,
and Paste commands are especially useful. Select the notes
you want to copy, using the Editor panel (or choose
Edit→Select All, if you like). Choose Cut or Copy from the
Edit menu, position the Playhead where you want the notes
to reappear, and choose Edit→Paste.

The musical material you copied or cut now appears, both
in the Editor panel and in the track display above.

Module 3: Live Audio
If you sing, speak, or play an instrument into your Mac,
GarageBand can save the results as digital audio files that
you can edit, stack up to create harmony, or process with
special sound effects.

Module 2: Virtual
Instruments



44 ilife ’04: the missing manual

Module 3:
Live Audio

Start by plugging in your microphone (or use the built-in
microphone on your laptop or iMac). Pay a visit to System
Preferences→Sound→Input tab, to make sure that the cor-
rect microphone is selected. (If you make any changes here,
quit and reopen GarageBand to activate them.)

Create a new track (Track→New Track). In the New Track
dialog box, click the Real Instrument tab. Click the kind of
instrument you’re about to play. If you intend to speak or
sing, click Vocals.

On the right side, specify what effects you want to apply to
your recording from a long list of reverb and other process-
ing effects. With a pair of headphones, you can try them out
one at a time by listening as you test your microphone. (Click
Unprocessed if you don’t want any special effects.)

Tip: The names in the right-hand column are the labels that Apple gave its
prefab sets of settings. You can view the details by opening the Details panel
at the bottom of the dialog box. There you’ll see that you can create and save
your own presets, too.

If you’re going to sing, you’ll probably want to use headphones
plugged into your Mac, so that the Mac won’t pick up the
other tracks as you sing along to them. (At the bottom of the
dialog box, the Monitor option controls whether or not you’ll
hear your own, live singing played through the speakers while
recording, as explained in Figure 4-6.)

When you click OK, the new track appears. Set up the Count
In and Metronome options described at the top of page 39,
click where you want to start recording (or click the Rewind
to Beginning button), and then click the round red Record
button. As it plays the tracks you’ve built so far, GarageBand
simultaneously records your live sonic performance.

When you’re finished recording, rewind (or click in the ruler)
and tap the Space bar to hear how you did. You can adjust
the relative volume as described on page 46.
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Then the fun begins—you can add another track, and an-
other, and layer your performances. If you’re musically in-
clined, you might want to sing harmony with yourself. And
even if you’re not, try singing exactly the same thing on
multiple tracks. That’s a trick that the Beatles used to use; it
creates a professional, studio-chorus sound.

Note: Your recordings appear as red bars, so you can distinguish them from
the blue and green GarageBand loops. (A key difference: you can’t change
the tempo or key of digital audio you record yourself. Sound files that you
drag into GarageBand from the Finder, and sound-effect loops like cymbal
crashes and crowd applause, also show up in red, to remind you of their
similar limitations.)

Getting It Right
It’s the rare performance that’s perfect on the very first try,
so GarageBand is designed to let you take several stabs at it.
You can hang on to all of your takes, and when you deter-
mine that one of them was indeed perfect, you can toss the
bad ones. Here are two ways to go about this process:

Figure 4-6: If you’re
using headphones,
turn the Monitor
option On so you can
hear yourself sing. If
you’re not using
headphones, turn it
off, so that you don’t
get the squealing
shriek known as
feedback as you sing.

Module 3:
Live Audio
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• Create a new track for each attempt. Use the Mute but-
ton described on page 37 to silence previous tracks as you
record the new ones.

• Rerecord over a certain passage. Even if you’ve already
recorded into a track, you can position the Playhead and
record a new take. The new sound will record over what
was already there, resulting in a new, distinct “block” in
the track display.

Putting It All Together
When your individual tracks are sounding good, it’s time to
start thinking of the composition as a whole. After all, your
public is waiting.

Track Volume Levels
To adjust the volume levels of tracks relative to each other,
expose the Mixer panel shown in Figure 4-7. (Either click
the right-pointing triangle next to the word Tracks, or choose
Track→Show Track Mixer.)

Here’s what the mixer panel lets you do:

• If you’re listening to your piece in stereo, you can specify
where a particular instrument is on the imaginary left-
to-right soundstage, just by clicking the edges of the “L R”
knob.

• You can make the overall volume of a track rise and fall
during the course of the piece. Just to the right of the Solo
(headphones) button is a down-pointing triangle that
makes a new Track Volume strip appear. See Figure 4-7.

• GarageBand also offers an overall volume map for the
piece; choose Track→Show Master Track to see it.

• You can adjust the reverb and other effects for any track
just by double-clicking its name. In the resulting box, ex-
pand the Details panel to view Gate, Compressor, Equal-
izer, and other effects. (You can also double-click the

Module 3:
Live Audio
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Master track’s name to apply an overall effect to all tracks
together.)

• You can adjust the tempo of the piece as described on
page 39, and you can transpose the key as described on
page 42. Remember, though, that making these changes
affects only the GarageBand’s loops and whatever you’ve
recorded with a USB or MIDI musical keyboard. You can’t
change the key or tempo of your live microphone record-
ings, so your singing should be a last creative step.

When the piece is done, you’re ready to bring it to your ador-
ing fans. Choose File→Export to iTunes. After a moment,
iTunes opens automatically, and your GarageBand piece ap-
pears in its music list.

From here, you can distribute your song anywhere that fine
iTunes songs are distributed: transfer it to your iPod, burn it
to a CD, export it as an MP3 (or AIFF or AAC) file, or just let
it play over and over again, with the iTunes laser-light show
filling your vision.

Figure 4-7: Once you’ve exposed the Track Volume strip, you can click on the colored
line—a graph of the track volume—to insert a handle, which you can drag to make the
volume rise and fall over time. (Make sure that the Track Volume checkbox is turned on
if you want to hear the effect.)

Putting It
All Together
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Available at www.missingmanuals.com or at your favorite online or local retailer.



The best Mac book, period.
Mac OS X: The Missing Manual is the best—and most popular—
Mac book of all time. Sink your teeth into the new Panther 
edition and start getting the most out of your Mac.

Available at www.missingmanuals.com or at your favorite online or local retailer.



Look for these upcoming titles at 
www.missingmanuals.com or at 

your favorite online or local retailer

Living the iLife?
Apple has done it again. The new iLife ’04 suite will soon 
revolutionize the way the world works—and plays—with digital
photography, video, and music. And with our brand new crop of
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